freezer works refrigerator doesn't Kenmore elite trio refrigerator

Reply

  #1  
Old 07-04-14, 01:04 PM
D
Member
Thread Starter
Join Date: Nov 2011
Location: usa
Posts: 219
Received 0 Votes on 0 Posts
freezer works refrigerator doesn't Kenmore elite trio refrigerator

Kenmore elite trio refrigerator
model #596.75534400

freezer compartment seems to be working but the refrigerator compartment is not.
it appears the fan (located behind the panel in the bottom freezer compartment)
is not working.

any ideas for diagnosis or repair will be most appreciated.
thank you
 
Sponsored Links
  #2  
Old 07-04-14, 04:05 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,148
Received 1,113 Votes on 1,033 Posts
I don't know how old your fridge is but it may need to be vacuumed and cleaned underneath. Make sure the condensor fan is running down there.

Your fridge has an electronic control board and temperature sensors in the fridge and freezer. Those can be a little difficult to troubleshoot.

You mentioned you didn't think the evaporator fan was running. In the following link it's pictorial part # 18. You'll need to remove the shroud to see if the motor is frozen/stuck or electrically defective. It run's on 120vac.

KENMORE ELITE Refrigerator Evaporator area & rollers Parts | Model 59675534400 | Sears Parts Direct
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: