Frigidaire Freezer Stopped Freezing??

Reply

  #1  
Old 12-27-14, 02:47 PM
L
Member
Thread Starter
Join Date: May 2006
Location: usa
Posts: 61
Received 0 Votes on 0 Posts
Question Frigidaire Freezer Stopped Freezing??

I have a Frigidaire upright freezer Model Number: MFU17F3GW8 that quit working. It's about 15 - 18 years old. It used to make a sucking sound when the door was closed as if it was pulling a vacuum. When it quit working, I no longer heard this familiar sound. My question is this: Is this something that an appliance repair business would be able to handle as a repair? Or, is this freezer destined for the junk yard? Thanks everyone, Larry
 
Sponsored Links
  #2  
Old 12-27-14, 03:26 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,078
Received 1,110 Votes on 1,030 Posts
Are you mechanically inclined ? Do you want to work on it yourself ?
You would need a volt/ohmmeter to make some tests.

My first guess would be a defective thermostat. The thermostat turns on the compressor and the evaporator fan. That fan is what draws the door closed.

Part 21 in the following link is the thermostat. You'd need to pull the panel covering it to get to it to check it. In you click on "view full size" under the diagram.... it will open in a new page. You can click on the new diagram for an exploded view.

FRIGIDAIRE Upright Freezer Cabinet Parts | Model MFU17F3GW8 | SearsPartsDirect


If the thermostat is ok then you'd need to check the defrost timer which is part 23 in the following link. You can click on "view full size" here also. The defrost timer is mechanical and may be stuck in defrost mode keeping the compressor shut off. The defrost timer is underneath and you can use a screwdriver to advance it manually.

FRIGIDAIRE Upright Freezer System Parts | Model MFU17F3GW8 | SearsPartsDirect
 
  #3  
Old 12-27-14, 03:32 PM
L
Member
Thread Starter
Join Date: May 2006
Location: usa
Posts: 61
Received 0 Votes on 0 Posts
Thanks, PJmax, I am mechanically inclined and enjoy working on things myself. i will follow your instructions and let you know how it goes. Thanks so much for the great information. Larry
 
  #4  
Old 01-19-15, 10:07 AM
L
Member
Thread Starter
Join Date: May 2006
Location: usa
Posts: 61
Received 0 Votes on 0 Posts
Finally got around to doing the things Pete suggested. The thermostat checked out okay but still not running. Went to rear of freezer and re-set the defrost timer with a screwdriver and it started running again. However, it is not getting cold. The compressor runs and the fan blows but not getting cold. Any help appreciated. Thanks everyone, Larry
 
  #5  
Old 01-19-15, 10:37 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,078
Received 1,110 Votes on 1,030 Posts
If the compressor is running and you aren't getting cold..... the refrigerant may have leaked out.
One of the compressor lines should be hot and the larger one should be cold.
 
  #6  
Old 01-20-15, 07:12 AM
L
Member
Thread Starter
Join Date: May 2006
Location: usa
Posts: 61
Received 0 Votes on 0 Posts
Thanks, Pete, I'll check it out and call someone if it has leaked out. Thanks for the great help. Larry
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: