SubZero freezer not cold enough

Reply

  #1  
Old 06-04-15, 08:22 PM
G
Member
Thread Starter
Join Date: Jun 2015
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
SubZero freezer not cold enough

I have a SubZero 511. The freezer stopped cooling properly a couple months ago: it doesn't get lower than about 15 degrees (no matter how high I turn it up) and often it's between 20-30 degrees. The fridge is working fine though.

A few weeks before I noticed this, the defrost timer started to making noises. I replaced the defrost timer but that the freezer didn't get any colder. I also don't see any frost in the freezer, which seems to be the common symptom when the defrost timer is broken.

Any advice? Thanks!
 
Sponsored Links
  #2  
Old 06-04-15, 08:59 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,148
Received 1,113 Votes on 1,033 Posts
Welcome to the forums.

Although these fridges are quality units they do have their share of problems. If you had a defrost problem the coil would be full of ice.

If the compressor runs all the time but it won't get cold enough then it's low on refrigerant due to a leaking evaporator (cold coil).

How old is the unit ?
You will more than likely need to call sub zero repair service in to have the sealed system checked.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: