Electric Stovetop Suddenly Stopped Working

Reply

  #1  
Old 08-06-15, 03:30 PM
Member
Thread Starter
Join Date: Jul 2005
Location: USA
Posts: 177
Received 0 Votes on 0 Posts
Electric Stovetop Suddenly Stopped Working

Sears Kenmore, model 790.9621340C, 8 yeasr old. Working fine yesterday. Today, suddenly, none of the burners will heat up. The indicator lights also stopped working. Oven, however, functions normally.
Blown fuse of some kind? Reset button somewhere? Help! Thank you!!
 
Sponsored Links
  #2  
Old 08-06-15, 10:33 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 52,721
Received 345 Votes on 323 Posts
It's actually pretty strange for all the burners to go out at one time. I believe the burner controls are daisy chained with 240volts. Most use a red and black wire. I would check for 240vac at the surface burner controls. I'm thinking a burned/broken wire from the burner controls to the supply at the back of the range.

There should also be a simmer control board but I think that only controls/affects one burner.

I can't find a wiring diagram so if this doesn't help..... locate the wiring diagram and post it and we'll go from there. It'll usually be in or on the back cover.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: