GE Profile PB975SP3SS range: one of the rings not heating

Reply

  #1  
Old 04-30-16, 08:07 PM
Member
Thread Starter
Join Date: Jun 2009
Location: Rockville, MD
Posts: 90
GE Profile PB975SP3SS range: one of the rings not heating

I have a GE Profile PB975SP3SS range that's about 6 years old. It has a 3-ring element, and we noticed that the middle ring is not heating. Questions:
1. Is this a complicated fix? Does this require replacing a part?
2. Whatever needs to be done, can it be done without moving the range, i.e. accessing it from the front not from the back? The reason for asking is that if I remember correctly from our kitchen renovation, it was pretty hard to squeeze it between the two pieces of the countertop so it might be hard to move it out.
 
Sponsored Links
  #2  
Old 05-01-16, 10:49 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 50,509
Likes Received: 104
Typically it's the element that goes bad but it could be a wiring or defective switch issue. You need to start by using an ohmmeter to check the element.

There are several elements used in that range. One of them is listed in the link below. There is a video in that link that shows how to check the element.

Radiant Surface Element WB30T10126 Repair Clinic

Always turn off electric to the range while working on it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes