Kenmore upright freezer high temp light on

Reply

  #1  
Old 08-13-16, 01:48 PM
Member
Thread Starter
Join Date: Aug 2016
Posts: 2
Kenmore upright freezer high temp light on

I have a Kenmore upright freezer model 253.28052808. The high temp warning light and alarm has randomly been going off. When it started I put a pretty accurate electronic thermometer in it. The freezer maintains temp at around -3 degrees f. Shutting the freezer off will reset the alarm for a while, but pretty soon it will go on again. I have noticed that it seems like the fan is always running when I check it. I'm pretty handy but don't know much about freezers and have no idea really where to start troubleshooting. Any help would be greatly appreciated.
 
Sponsored Links
  #2  
Old 08-13-16, 02:33 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 51,376
Upvotes Received: 206
Welcome to the forums.

The alarm should not sound until the tem rises over 23 degrees.
Do you have the freezer with the LED readout ?

I have to check further but it sounds like it may be a defective control board.
 
  #3  
Old 08-13-16, 03:23 PM
Member
Thread Starter
Join Date: Aug 2016
Posts: 2
It does have a screen on the control panel that reads the coldness setting from 0-7
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes