Kitchen-aid dishwasher stuck on wash cycle

Reply

  #1  
Old 08-11-17, 01:13 PM
A
Member
Thread Starter
Join Date: Aug 2017
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
Kitchen-aid dishwasher stuck on wash cycle

I have a Kitchen-aid dishwasher (model KDTE704DSS0) that has been acting up. It runs normally at first, then somewhere in the wash cycle it gets stuck. There is a click sound and all lights turn off; then it comes back on and makes a "woosh" sound; then it clicks off again. This will repeat for hours without stopping. The water seems to fill and the dishes come out clean, but if it runs too long there is a funky stank to the inside.

I pulled the customer default codes and there was one related to the door latch. I cleared the code and checked the latch mechanism and continuity and it all seemed fine. After running the machine a few more times, this code did not return. However, I can not seem to figure out how to get the diagnostic cycle to advance past displaying the customer codes - it just gives me a long beep and does not advance to the actual diagnostic cycle. Surely I'm doing something wrong.

After Googling around, and I found somewhere that it was likely either the thermistor/turbidity sensor or the control board, so I just replaced both and crossed my fingers. Unfortunately, the problem persists exactly as before. I also checked the heater element/high-heat thermostat and there is continuity through both.

Does anyone have any suggestions on where to go next or how to trigger the diagnostic cycle? Any help or direction is greatly appreciated. Thank you.
 
Sponsored Links
  #2  
Old 08-11-17, 02:20 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 56,259
Received 732 Votes on 687 Posts
Welcome to the forums.

We were just discussing intermittent problems with dishwashers. The manufacturers put the hot air vent near the control board causing it to do intermittent things from the damp air.

The latch switch handles a lot of current and does fail quite routinely.

It seems you've pulled the tech sheet out. Is it labeled W10543820 ?
 
  #3  
Old 08-13-17, 03:54 PM
A
Member
Thread Starter
Join Date: Aug 2017
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
Thank you for your reply. The latch part number is W10653840.

I just checked error codes again and now it is giving me 8-2, which is a fill valve electrical problem. The tech sheet says the resistance should be 890-1040 ohms, and the valve is reading ~1400. Could this be an issue?
 
  #4  
Old 08-13-17, 04:56 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 56,259
Received 732 Votes on 687 Posts
If the board recognizes that resistance as a problem then the solenoid will need to be replaced. Be sure to check it right at the solenoid to eliminate and wiring issues.

The number I left was for the tech sheet (mini service manual) for the unit.
 
  #5  
Old 08-13-17, 05:50 PM
A
Member
Thread Starter
Join Date: Aug 2017
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
Oh I see. Yes, that is the number for the tech sheet.
 
  #6  
Old 08-19-17, 10:51 AM
A
Member
Thread Starter
Join Date: Aug 2017
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
I'm still experiencing the same problem. I just replaced the fill valve and the machine is still stuck on the wash cycle. Any thoughts on how to diagnose this? I'm still perplexed about advancing the diagnostic cycle past the customer error codes. Any help is greatly appreciated.
 
  #7  
Old 08-19-17, 01:26 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 56,259
Received 732 Votes on 687 Posts
I'm out in the field today. I'll try again to locate that tech sheet when I return.
 
  #8  
Old 08-19-17, 02:18 PM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 8,798
Received 50 Votes on 46 Posts
You could have a button stuck that would cause problem. Control panel is 200+ at one site. Need tech sheet so you can check.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: