Whirlpool electric dryer


  #1  
Old 04-21-18, 09:34 AM
J
Member
Thread Starter
Join Date: Jan 2003
Posts: 55
Upvotes: 0
Received 0 Upvotes on 0 Posts
Whirlpool electric dryer

I have a whirlpool dryer Model wed4900xwo& it wouldnt run so I replaced the timer in it ,it had a burned out contact,after I installed the new timer I ran it through the cycles&it was running,but after I put it all back together,it wont run it hums & has a burning smell! Any advice on this will be appreciated!
 
  #2  
Old 04-21-18, 10:39 AM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 8,161
Received 77 Upvotes on 70 Posts
Did you put all the wires on the timer right. They are all labeled. Next tape down door button or have somebody hod it in.Turn dryer on Push start button and turn drum at the same time. If it starts you need a motor.
 
  #3  
Old 04-21-18, 10:56 AM
2
Member
Join Date: Jan 2014
Location: USA near Boston, MA
Posts: 2,319
Received 394 Upvotes on 343 Posts
May only need a new belt and not a new motor. The burning smell could have been from the motor pulley turning against a stationary belt.
 
  #4  
Old 04-21-18, 01:52 PM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 8,161
Received 77 Upvotes on 70 Posts
Did you pull the lint screen out when you were changing the timer? I have seen things dropped down there and jams the blower.
 
  #5  
Old 04-22-18, 11:28 AM
J
Member
Thread Starter
Join Date: Jan 2003
Posts: 55
Upvotes: 0
Received 0 Upvotes on 0 Posts
Smile Whirlpool electric dryer

You were right1When I found the motor wouldnt turn I got into itfurther,I cleaned it out&lubed it hen got it to turn,then it jammed again,took back apart exhaust duct, it was very clogged&at the bottom the blower was stuckdue to a lot of debris in it,cleaned all that out&finally got it to work,to make a long story short $70 for a refurbished timer&a lot of labor it s working much better!Thank you for all of your help! Jim
 
  #6  
Old 04-22-18, 12:53 PM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 8,161
Received 77 Upvotes on 70 Posts
Be sure to clean vent to the outside or you will have other problems.
 
  #7  
Old 04-23-18, 07:58 AM
J
Member
Thread Starter
Join Date: Jan 2003
Posts: 55
Upvotes: 0
Received 0 Upvotes on 0 Posts
Smile

Already vented! I replaced the old vent too!Thank u!Jim
 
  #8  
Old 04-23-18, 12:37 PM
2
Member
Join Date: Jan 2014
Location: USA near Boston, MA
Posts: 2,319
Received 394 Upvotes on 343 Posts
Did you check the belt to make sure there was no "burn' damage? Or was the motor jammed such that it could not rotate against the belt?
 
  #9  
Old 04-23-18, 01:50 PM
J
Member
Thread Starter
Join Date: Jan 2003
Posts: 55
Upvotes: 0
Received 0 Upvotes on 0 Posts
Motor was jammed couldnt rotate!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: