Kenmore washing machine restarts after finishing cycle


  #1  
Old 07-08-22, 04:31 PM
E
Member
Thread Starter
Join Date: Aug 2013
Posts: 148
Received 0 Upvotes on 0 Posts
Kenmore washing machine restarts after finishing cycle

A few months ago I overloaded the washer with blankets and from googling it I assume water shorted the control board or something. As the topic states, the machine still works but after a cycle finishes, if the cover isn't opened right away (and it still has the "complete" light lit up), the sensing and fill process starts again after a few minutes. It runs through the entire cycle again and where the problem occurs again and again and again until the lid is open or the cycle is canceled/drained.

A control board is expensive for a washer that still mostly works. Is there some other cheaper repair that might help? It's a Kenmore model: 110.25102310

Thanks
 
  #2  
Old 07-09-22, 09:52 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,928
Received 4,139 Upvotes on 3,717 Posts
It would appear to be a defective control board.
The start button is part of that control....correct ?

Pretty strange problem.
Have you tried unplugging the machine for a few minutes to reset the control.
 
  #3  
Old 07-09-22, 01:53 PM
E
Member
Thread Starter
Join Date: Aug 2013
Posts: 148
Received 0 Upvotes on 0 Posts
Yeah, it looks like it but I haven't actually taken it apart. I've thought about it though, lol I'm always surprised how long moisture can last in tight, enclosed electronics (i.e. phones). It's a strange problem indeed lol and I don't really want to spend $200 on a machine that works as long as I am paying attention to it lol. I have not tried unplugging but that might just work! Will report back..

Ty!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: