GE Toaster-Oven TOP ELEMENTS DON'T WORK

Reply

  #1  
Old 12-08-07, 08:13 AM
Member
Thread Starter
Join Date: Dec 2007
Posts: 2
Received 0 Votes on 0 Posts
Question GE Toaster-Oven TOP ELEMENTS DON'T WORK

I HAVE GE DELUXE TOAST-R-OVEN -- top heating elements stopped working. is there an easy fix for this?
 
Sponsored Links
  #2  
Old 12-08-07, 02:16 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
Received 0 Votes on 0 Posts
Do those elements always work no matter how you set it to run? If so, it's probably - toast? Easy diagnosis, I'd imagine, if you had multimeter to check resistance of element when unplugged.
 
  #3  
Old 12-09-07, 06:33 AM
Member
Thread Starter
Join Date: Dec 2007
Posts: 2
Received 0 Votes on 0 Posts
Unhappy MORE about GE toaster problem

Top elements should work when toaster oven set to "toast" but doesnt'. A quick look at ends of the elements shows intact connections. Any suggestions (for the electrically rather unsophisticated)?
 
  #4  
Old 12-09-07, 01:10 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
Received 0 Votes on 0 Posts
You need a handy brother-in-law because the tests I'd imagine should be straight forward. But unless you have a mulitmeter and have been used to testing with one, I think you need to find someone who can trace your outage.

I know how to do this stuff, yet when my brother-in-law came to visit HE wanted to be the one to take apart my parents toaster to figure it out. He's that way.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: