Europace standing fan button issue


  #1  
Old 05-07-17, 04:29 AM
D
Member
Thread Starter
Join Date: Jun 2014
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
Europace standing fan button issue

There's an issue with my standing fan's buttons.

It's either not responsive, or activates the wrong function (e.g. Speed button will become oscillate function). Any idea how I can DIY the repair? Doesn't look like a serious problem to me, but it is definitely annoying. Video provided below.

https://vimeo.com/216365032
 
  #2  
Old 05-07-17, 08:52 AM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 8,161
Received 78 Upvotes on 71 Posts
Can't find any info or parts for fan. Model # might help.
 
  #3  
Old 05-07-17, 09:07 AM
Shadeladie's Avatar
Super Moderator
Join Date: Jan 2005
Location: PA - USA
Posts: 4,937
Received 407 Upvotes on 334 Posts
Member appears to be in Singapore. Perhaps it's a fan just sold overseas?
 
  #4  
Old 05-14-17, 07:03 AM
D
Member
Thread Starter
Join Date: Jun 2014
Posts: 7
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks guys. The model number is ESF 1689.

Do I need to get replacement parts or something?
 
  #5  
Old 05-14-17, 02:13 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,985
Received 4,152 Upvotes on 3,729 Posts
I have not found any replacement parts for that fan. It's made in Singapore.
Many companies like that one DON'T offer any replacement parts or technical info or advice.

I'd recommend contacting them directly. Contact Us
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: