Central vacuum - Hose stopped working - FIXED

Reply

  #1  
Old 04-11-19, 06:31 PM
Member
Thread Starter
Join Date: Jan 2014
Location: Canada
Posts: 97
Central vacuum - Hose stopped working - FIXED

As I was typing my question, I investigated a little more and found the solution. I thought I'd post this nevertheless so that other can benefit from my findings.

Hi,

I have a central vacuum and this week I noticed that I couldn't get it to work anymore. After some testing, I discovered that:
1- The central unit works fine
2- If I use another hose it works fine
3- With the current (non-working)hose, if I pull it out a bit and twist it, it works correctly.

I also discovered that there are 2 metal contacts at the top of the hole in the wall, and shorting those 2 contacts with a paper-clip will start the vacuum. I can conclude that my hose is no longer shorting those 2 pins.

Using a multi-meter to test continuity I was able to determine that the on-off switch on the hose wasn't shorting the 2 metal plates at the end of the hose. I opened the handle where the on/off switch is and was able to confirm that the on-off switch was working properly.

I then opened the other end (the one that goes in the wall and found the issue: One of the 2 wires wasn't connected to the metal plate anymore. Unfortunately I didn't take a picture of the hose when the problematic end was opened, but here is a photo of how it looks at the other end and it was that metal "clip" that was separated from the wire.

Name:  IMG_20190411_194911.jpg
Views: 23
Size:  3.14 MB
 
Sponsored Links
  #2  
Old 04-14-19, 04:36 AM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: Raleigh, NC
Posts: 8,164
Good ob never know when it will help somebody down road.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes