Keurig K60

Reply

  #1  
Old 10-09-19, 06:08 AM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,016
Received 17 Votes on 17 Posts
Keurig K60

Hi All, Keurig has been sitting for awhile, we went to use it this AM , it indicates ready to brew I select the cup size and it clicks twice and then nothing, almost sounds like a pump issue, any thoughts?
PS filters etc.have been cleaned
Geo
 
Sponsored Links
  #2  
Old 10-09-19, 11:38 AM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 20,998
Received 224 Votes on 206 Posts
Keurig are fun to take apart. Lots of neat stuff inside. Surprisingly complex machines.

I suspect the water evaporated away and mineral deposits have stuck a valve or the pump. I have never seen internal parts being sold so I think you are stuck trying to fix what you have. Once you are certain it's dead and have nothing to loose I would open it up (take lots of pictures so you can put it back together). Start following the water's path through the machine and pay special attention to valves and pumps. Some CLR, vinegar or other acid (muriatic) can dissolve mineral deposits without having to take the pumps or valves apart.


I only use distilled water in my office Keurig that will sometimes sit for months without use. When the water evaporates away there are no mineral deposits to seize valves and pumps.
 
PJmax voted this post useful.
  #3  
Old 10-09-19, 04:38 PM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,016
Received 17 Votes on 17 Posts
I did take the bottom off and check the pump and it was free but didnít go any further, really sounds like an overload or something that snaps, tried it after I checked the pump and same result, JUNKED, I think I will use distilled water to flush it out at end of season.
Geo
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: