Bath fan w/humidity sensor not working

Reply

  #1  
Old 06-12-09, 07:33 AM
Member
Thread Starter
Join Date: May 2003
Location: Suburb of Detroit
Posts: 283
Received 0 Votes on 0 Posts
Bath fan w/humidity sensor not working

Hi, I have a humidity-sensing bath fan. It's a Broan HS90-B and their customer service said it's either the humidity sensor or the motor. The access from above is VERY difficult, so I want to replace the bad part and not the whole unit. The problem is, I don't have a wall switch, so I can't just turn the fan on manually to see if the motor works. I think the sensor is bad (just a hunch) and I would like to power up the motor somehow to verify this.

I can't just bypass the sensor because this unit uses specialized wire connectors (see picture). WHAT ARE THOSE CALLED??? In the second picture, you see the three-pronged male on the humidity sensor takes a female plug from the line voltage (white, black, red). I believe the red isn't used since I don't have a switch involved. The two-pronged male on the sensor takes the female you see that goes to the motor.

I had one thought that I could tap into a receptacle in my shop and flip the breaker on to see of the motor starts. Not sure if this could be dangerous or fry the motor, so I wanted to ask first. My other thought was to clip the wire connectors off, then wire nut the power line directly to the motor to test. Then attach new wire connectors. Problem is, Radio Shack didn't have those connectors and I have no idea what they are called. Thoughts?



 
Sponsored Links
  #2  
Old 06-12-09, 08:36 AM
Forum Topic Moderator
Join Date: Sep 2005
Location: USA
Posts: 4,689
Received 28 Votes on 27 Posts
I think you're on the right track with your planned testing. I wouldn't cut off that connector, because as you said, you don't want to have to replace it. Get an old lamp cord or something with a plug on one end and stripped wire on the other. Shove the stripped wire into the connector and wrap it with electrical tape. The stranded wire should make good enough contact for a test.

Next, stand a few feet back and plug it in. I'd certainly use a GFI outlet for this test, just in case. It's an easy way to test the motor.

I'd bet that it's the humidity sensor though. These motors usually fail by getting real loud. I haven't seen one just fail yet.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: