Thermostat installation issue

Reply

  #1  
Old 02-07-14, 03:01 PM
Member
Thread Starter
Join Date: Feb 2014
Posts: 2
Received 0 Votes on 0 Posts
Thermostat installation issue

I just installed a new wifi honeywell thermostat at my house. After I connected the wires to the proper terminal, I connected the faceplate and went and turned on the power from the surge box. The thermostat came on but I noticed that the faceplate was sticking out a little so impressed it in and the thermostat turned off. I took off the faceplate and noticed that one of the wires broke. So I took out the broken piece of wire from the terminal and then put the wire back into the terminal. When I went back to turn on the surge protector nothing is happening. The unit is not turning on. Any ideas?
 
Sponsored Links
  #2  
Old 02-07-14, 03:50 PM
Temporarily Suspended
Join Date: Jul 2008
Location: NY
Posts: 10,986
Received 0 Votes on 0 Posts
Is it a low voltage thermostat or 110? Did you buy the correct replacement?
 
  #3  
Old 02-07-14, 06:07 PM
Member
Thread Starter
Join Date: Feb 2014
Posts: 2
Received 0 Votes on 0 Posts
I know that I bought the correct thermostat.
 
  #4  
Old 02-07-14, 06:25 PM
Temporarily Suspended
Join Date: Jul 2008
Location: NY
Posts: 10,986
Received 0 Votes on 0 Posts
If it's low voltage, touch the wires together & see if the burner starts. If it does, connect the thermostat again. If it's programmable, set the temp & press hold. That way it will override what ever the default setting is. If it's not programmable, raising the temp high enough should start it.
 
  #5  
Old 02-07-14, 08:42 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 54,685
Received 522 Votes on 491 Posts
If the unit wasn't sitting on the backplate correctly and you pushed the thermostat in harder..... you may have bent one of the contact pins.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: