Losing Outlets - Open Neutral

Reply

  #1  
Old 07-24-15, 08:42 PM
Member
Thread Starter
Join Date: Jul 2015
Location: USA
Posts: 1
Losing Outlets - Open Neutral

I've been in my house 10 years. During a new flooring project, I moved the refrigerator (and everything else into the garage). The refrigerator worked fine for two weeks, then the outlet stopped working. I have an electrical tester and it said open neutral. The next week, the outside outlet stopped working, and it said open neutral. Then the bathroom outlets stopped working and all three say open neutral now. Most of the outlets that stopped working are GFCI. What could be going on and how to fix it? Yes, I tried resetting all of the outlets.
 
Sponsored Links
  #2  
Old 07-24-15, 09:40 PM
ray2047's Avatar
Group Moderator
Join Date: Mar 2006
Location: USA
Posts: 33,042
Most of the outlets that stopped working are GFCI.
Best practice is only one GFCI per circuit if down stream receptacles are fed from the load side of the GFCI. GFCIs fed by the load side of a previous GFCI can be problematic.
I have an electrical tester and it said open neutral.
Or something else. They can be fooled. You need to use a multimeter, preferably analog.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes