AL CU Wire Connection: I'm assuming this is wrong...

Reply

  #1  
Old 06-25-19, 09:38 PM
Member
Thread Starter
Join Date: Jun 2019
Location: United States
Posts: 2
AL CU Wire Connection: I'm assuming this is wrong...

I just pulled out the 30 year old wall oven in my house. The wiring from the wall is aluminum and the wiring from the old oven was copper. The 4 pairs of wires were all connected with an AL-CU split lug but the connections weren't actually split. The aluminum and copper wires were just smashed together in the lug.

I am assuming that the new oven should have the wires actually split by the lug. Or am I missing something? The wires didn't show any sign of oxidation.

Thanks,
Bob
 
Attached Images  
Sponsored Links
  #2  
Old 06-26-19, 12:46 AM
Member
Join Date: Mar 2006
Location: Wet side of Washington state.
Posts: 18,452
Likes Received: 12
Are you certain you have aluminum conductors? In the picture it looks like "tinned" copper conductors. Look at the cut ends and see if they look like copper or take a knife and scrape the conductor to see if it is simply a tin plating over copper.
 
  #3  
Old 06-26-19, 09:58 AM
Member
Thread Starter
Join Date: Jun 2019
Location: United States
Posts: 2
It looks like it's aluminum. The cut ends are all silver and the ground wire has been stripped of insulation for about 8" and it's all silver too.

-Bob
 
Attached Images  
  #4  
Old 06-26-19, 11:43 AM
Member
Join Date: Feb 2016
Location: United States, Virginia
Posts: 1,122
Likes Received: 17
On the Al/CU split bolts the wires are to be separated by the divider, not connected and touching together on one side of the divider.
 
CasualJoe liked this post.
  #5  
Old 06-27-19, 02:49 AM
pcboss's Avatar
Forum Topic Moderator
Join Date: Jul 2002
Location: Maryland
Posts: 14,818
Likes Received: 6
The pre-insulated connector like Polaris are nice . No need for all the taping required with split bolts.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes