Outlet stopped working

Reply

  #1  
Old 07-14-19, 03:54 PM
L
Member
Thread Starter
Join Date: Jul 2019
Posts: 2
Received 0 Votes on 0 Posts
Outlet stopped working

Okay so for the last 4 days or so I have been running my new 8000 BTU window air conditioner. Everything works great and ran properly in the room but all of a sudden the air conditioner unit stopped working, thinking that I tripped the breaker I checked the Box and I have not (I did flip it Off and on a couple times). Every other outlet still works in that room and the A/C until still works (tested it.) I got a tester and the light indicator says "open ground" I have opened up the outlet and changed the "backstab" method to the side screws. Still nothing. I have checked some of the other outlets and they all still work and can operate things. Ugh, what can I do or check??
 
Sponsored Links
  #2  
Old 07-14-19, 03:56 PM
J
Member
Join Date: Sep 2002
Location: welland ontario
Posts: 7,520
Received 236 Votes on 207 Posts
Check the receptacles next to it in the room. The outgoing connection could be bad on one of them especially if they also used the back stab.
 
  #3  
Old 07-14-19, 04:05 PM
L
Member
Thread Starter
Join Date: Jul 2019
Posts: 2
Received 0 Votes on 0 Posts
Hi Joed,

I used the indicator and have things running on the other outlets. (2 Fans, t.v. and a lamp). Ugh. 🤔
 
  #4  
Old 07-14-19, 07:56 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 58,402
Received 1,018 Votes on 945 Posts
Welcome to the forums.

With that tester......an "open ground" means you lost the neutral. Those testers aren't very helpful for troubleshooting. A basic analog meter or two probe voltage checked is better.

You need to identify everything on that circuit. If it's just the A/C receptacle that is dead...... look for the closest receptacle on that circuit that is working. That's most likely where you'll find a loose neutral. It may not be on a device. An open neutral can be a splice in a wirenut.

If you have more back stabbed connections...... correct them.
 
Pea-Jay voted this post useful.
  #5  
Old 07-14-19, 09:09 PM
J
Member
Join Date: Sep 2002
Location: welland ontario
Posts: 7,520
Received 236 Votes on 207 Posts
I used the indicator and have things running on the other outlets. (2 Fans, t.v. and a lamp). Ugh. ��
It doesn't matter the other receptacles are working. The incoming power connections could be good but the outgoing power connection could be bad.
 
CasualJoe voted this post useful.
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: