Drill Press question

Reply

  #1  
Old 08-30-04, 03:42 PM
sandy2000's Avatar
Member
Thread Starter
Join Date: Nov 2000
Posts: 198
Drill Press question

My 20 year old Craftsman 8" drill press, model 113.21372, has started acting up. When I start to lower the spindle (??) drill there is a slight resistance and then a one time clicking noise. It happens only when I first start. I've lowered the spindle as far as it would go and inspected the shiny cyclinder (??) it is well lubricated and I couldn't see anyplace that appeared to be wearing. All external nuts etc have been retightened. Any suggestions as to what I can check next?
 
Sponsored Links
  #2  
Old 08-31-04, 07:21 PM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 9,693
sandy2000,

The bearing in the spindle could be worn or even just dirty.

I couldn't locate a parts breakdown from Sears with the model number you gave.
Before you consider taking it apart you might try cleaning the spindle.
I have cleaned mine by putting a pan under the spindle and flooding the mechanism with WD-40.
You might be surprised how much gunk comes out.

If this doesn't take care of the noise you may have to take it apart to check it out.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'