Pressure washer

Reply

  #1  
Old 07-27-05, 12:59 PM
Jim St
Visiting Guest
Posts: n/a
Pressure washer

I have a Craftsman pressure washer with a 5.5 Honda engine. My problem is that it starts fine while having the power nozzle engaged but when I let off of the nozzle, the engine cuts off. I have let the engine warm up and when I try to cut back on the choke it wants to cut off also. Is this a tune-up problem or something else? Thanks.
 
Sponsored Links
  #2  
Old 07-27-05, 07:34 PM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 43,592
Welcome to the forum
Since it won't run with out the choke I would suspect tune up or carb adjustment. I have a comet with 5hp honda which has always run fine until I used it last weekend. Like yours mine won't run when you release the trigger. Mine runs great [with out choke] while washing. If someone posts the fix for yours let us know - it might give me a leg up on repairing mine.
 
  #3  
Old 07-28-05, 08:30 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Huh...
Boy does this sound familer
Maybe we can get a volume discount
My Craftsman won't stay running w/o the choke
Once I start spraying it's OK
I assumed it's in need of a tune-up or adjustment of some sort
I figured I'd take it in but I just can't take it out of service right now
I've been dealing with it
I don't know if it'll make it till Autumn though
I'm sure it'll just get worse
Guess I'll hang out with you guys in the mean time, if you don't mind
Maybe someone will come along with a fix
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'