Air Compressor Problem

Reply

  #1  
Old 10-10-06, 10:38 AM
A
Member
Thread Starter
Join Date: Oct 2006
Posts: 2
Received 0 Votes on 0 Posts
Air Compressor Problem

I have a 25 Gal. 5.5 HP Craftsman Vertical Copressor. It has recently started to trip the breaker evey time it is plugged in. There is no pressure in the tank and the outlets that have been used are all good and providing enough amps.

I have visited sears.com and found all the parts break downs, but it wont trouble shoot it for me and their service counter happens to know less than me. Can any one help with this problem?

Thanks
 
Sponsored Links
  #2  
Old 10-10-06, 05:50 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,967
Received 5 Votes on 5 Posts
Does it trip the breaker with the unit turned off, or are you plugging it in with a load on it?
 
  #3  
Old 10-11-06, 09:15 AM
A
Member
Thread Starter
Join Date: Oct 2006
Posts: 2
Received 0 Votes on 0 Posts
Once it is turned on it trips the breaker.
 
  #4  
Old 10-11-06, 11:45 AM
AxlMyk's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: Earth
Posts: 889
Received 0 Votes on 0 Posts
Disconnect the motor from the compressor.. See if the compressor shaft turns.. If not, it's locked up.. Run the motor to see if it's the problem..
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: