MTD Yardmachine Snowblower flooding, won't run

Reply

  #1  
Old 01-02-10, 03:28 PM
T
Member
Thread Starter
Join Date: Jan 2010
Location: MA
Posts: 1
Received 0 Votes on 0 Posts
MTD Yardmachine Snowblower flooding, won't run

I"m sorry if this is a repeat, but I've looked through the forum and didn't find a solution to this one. I have an MTD Yardmachine snowblower model 31-32AD700.
I used the machine fine a week ago, now when I go to prime it today gas drips out of the carburetor. I used a fuel additive, no difference. I took the carb apart and cleaned the pin. The float is intact with no obvious leak. The gas line is clear. I adjusted the screw on the bottom, trying different amounts, but none have done the trick. When I prime the gas I can see gas squirting out of the green tiny tube that's in the center of the chamber. I presume that means that the fuel system is OK leading up to that point.
The engine will start, but dies after a few seconds, sounding like it doesn't have enough gas.
I'm actually considering seeking professional help, for me and for the machine.
Thanks in advance
 
Sponsored Links
  #2  
Old 01-03-10, 05:16 AM
M
Member
Join Date: Oct 2003
Location: PA, USA
Posts: 748
Received 0 Votes on 0 Posts
Could be that the seat for that pin has worn out and is flooding the carb. You could try and change it, but I would just spring for a whole new carb.
 
  #3  
Old 01-03-10, 05:42 AM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Location: USA
Posts: 25,834
Received 642 Votes on 594 Posts
Maybe a dried out gasket that needs to be lubricated or replaced.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: