Pressure washer has no seal ?

Reply

  #1  
Old 12-03-15, 04:58 AM
I
Member
Thread Starter
Join Date: Dec 2015
Location: United Kingdom
Posts: 1
Received 0 Votes on 0 Posts
Pressure washer has no seal ?

Hi Everyone,

I was wondering if anyone could help me in fixing my Pressure washer ?

I have a K4 Karcher pressure washer that's stopped working properly. When you connect the hose pipe to the machine it automatically sprays water even when not turned on ( usually you have to have it plugged in and be pressing the trigger for the water to come out ) if you plug it in and then connect the water, the quick-fitting pipe union burst out along with the gun ... Does anyone know how to fix it ? Thanks in Advance for any help

Alex

The quick fitting pipe union - http://www.amazon.co.uk/Karcher-High.../dp/B004WCAKMK
 
  #2  
Old 12-03-15, 06:30 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 24,441
Received 750 Votes on 689 Posts
First make certain that you are propperly connecting the quick disconnect that it is locked before turning on the water. The sleeve on the female you pull down when inserting the male part must return to the full up position to lock it in place. If it doesn't lock you might have mismatched fittings or some crud in the fitting. Sometimes a squirt of penetrating oil can make them operate more smoothly.

If your fitting is securely connected and you're getting a bad leak then I replace the fitting. There is an O ring that you can replace but many places charge almost as much for the O ring as a new quick disconnect.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: