Air compressor hose connection problem

Reply

  #1  
Old 07-14-16, 11:57 AM
Member
Thread Starter
Join Date: Jul 2016
Posts: 1
Received 0 Votes on 0 Posts
Air compressor hose connection problem

I've been looking over your air compressor threads and I haven't seen my particular problem. I hand a Bostitch 6gallon, 150PSi oil free compressor. I've had it for a few years, using it primarily with my nail gun and it has worked fine. Today, it began spitting out the air hose at the quick release connector on the compressor.Has anyone else dealt with this problem?
Thanks
 
Sponsored Links
  #2  
Old 07-14-16, 12:09 PM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Location: USA
Posts: 23,868
Received 298 Votes on 271 Posts
Lube your quick release connector... if that doesn't help, replace the connector.
 
  #3  
Old 07-14-16, 01:26 PM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 46,504
Received 167 Votes on 148 Posts
Do you drain the moisture out of the tank after each day's use?
 
  #4  
Old 07-14-16, 08:33 PM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 10,064
Received 19 Votes on 19 Posts
The ball bearings in the female part are likely seized up and not gripping.
If you liberally spray WD-40 into the sliding part of the connector it should free it up and work fine.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: