Circular Saw not working


  #1  
Old 03-03-02, 11:32 AM
slalomx
Visiting Guest
Posts: n/a
Angry Circular Saw not working

I have a basic Skil circular saw that is having a problem. When sawing a 2 x 4, the blade will stop rotating soon after digs into the wood. It was working fine the other day, but now I can't even cut a 2 x 4 cause the blade stops. Could it be I need a new blade? It's only a year old and hasn't been used much. Or is there something wrong with the motor?

Thanks.
 
  #2  
Old 03-03-02, 02:09 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 12,231
Received 134 Votes on 104 Posts
When you say it stops rotating, does the motor continue to humm or make any noises or does it just quit entirely?
 
  #3  
Old 03-03-02, 02:39 PM
slalomx
Visiting Guest
Posts: n/a
The motor still runs, just the blade stops.
 
  #4  
Old 03-03-02, 03:44 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 12,231
Received 134 Votes on 104 Posts
Blade properly installed and the mount bolt tight? If so, may be time for new blade. Get a carbide and avoid the low price throw-away blades.
 
  #5  
Old 03-04-02, 09:38 AM
GasGuzz
Visiting Guest
Posts: n/a
I'm with the Tow.
"basic Skil circular saw" normally would not come with a carb blade.
Motor brushes? If it runs without a load, then it's fine (probably not the case if it's yr old for home use).
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: