Kidde CO Detector Giving Single Beep/Day: Why ?


  #1  
Old 07-05-05, 08:16 AM
R
Member
Thread Starter
Join Date: Apr 2005
Location: MA
Posts: 282
Received 0 Votes on 0 Posts
Kidde CO Detector Giving Single Beep/Day: Why ?

Hello:

Have a new Kidde Nighthawk plug-in CO detector (Model 900-0076 AC) for
house.
Seems to work fine, but -

About every other day or so, it gives a single beep.
Never more than one beep, and never more than once a day.

Replaced the backup battery with a brand new one.
The unit is plugged into the wall socket, so is working off of the AC,
normally.
The outlet is relatively close to floor. Floor has a rug.

Any idea why this single beep may be occuring ? Might it be dust from
the rug ?

Is it systamatic for these types of gadgets ?

No big deal, but certainly annoying and disconcerting.

Any thoughts on would be appreciated.

Thanks,
Bob
 
  #2  
Old 07-05-05, 12:51 PM
M
Forum Topic Moderator
Join Date: Jun 2000
Location: Gainesville, FL, USA
Posts: 17,017
Received 139 Votes on 128 Posts
Accordingto the Kidde site, these units do a periodic self test (when it does so, the display will show an 888 on the display, and chirp for a moment).
 
  #3  
Old 07-06-05, 05:11 AM
R
Member
Thread Starter
Join Date: Apr 2005
Location: MA
Posts: 282
Received 0 Votes on 0 Posts
Hello:

Wow; that is just the answewr I was looking for.
Much thanks.

Might you please be able to post the link on the Kidde site where it says that it
does a "beep" as well as showing the "888" during the self-test ?

I wasn't able to find it, and would like to read up on it.

Much thanks, and best regards,
Bob
 
  #4  
Old 07-06-05, 02:47 PM
M
Forum Topic Moderator
Join Date: Jun 2000
Location: Gainesville, FL, USA
Posts: 17,017
Received 139 Votes on 128 Posts
It's buried pretty deep on the website. This is the link to the PDF manual. The display information is on page 20 of 24.
 
  #5  
Old 07-08-05, 04:14 AM
R
Member
Thread Starter
Join Date: Apr 2005
Location: MA
Posts: 282
Received 0 Votes on 0 Posts
Thanks for Info. Still A Question regarding

Hello:

just a quick thank you for the info., and page reference.

I spoke to the Kidde rep on the phone, and he pointed me to the page you did.

But, I was also able to get the extension of one of their engineers who really seems like he knows the unit inside and out, and says absolutely no chirp when it does any self-test, if things are normal.

One could also interpret the chart you referenced me to on pg 20, the first line, that it "might" mean only will give a single chirp for when the unit is RE-plugged in ? Hard to tell.

So, still uncertain, I guess.

Will try and pursue it a bit more.

Thanks again,
Bob
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: