PC1555RKZ Keeps Chirping


  #1  
Old 02-23-08, 02:55 AM
F
Member
Thread Starter
Join Date: Oct 2007
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
PC1555RKZ Keeps Chirping

I have an American Ranger PC1555 Alarm system with PC1555RKZ keypad. It has been chirping for couple of months and now we are annoyed by it. The system is almost 7 years old and it was never monitored. How do I get rid of the sound and reset the system light which stays on.
When I press *2, the system light blinks but no zone lights show up. When a door or window is opened in a zone it does beep and zone light comes on as in normal operation.
I do not have master code or installer code. I am not sure if Master code was reprogrammed.
Please help!
 
  #2  
Old 02-23-08, 06:35 AM
M
Forum Topic Moderator
Join Date: Jun 2000
Location: Gainesville, FL, USA
Posts: 17,634
Received 251 Likes on 230 Posts
If it just recently started beeping after all this time, I would guess that the the problem is low battery. It's very odd that you are showing the system light, but nothing shows when you press *2.

It's a basic DSC (Ranger is just a dealer that sells enough to pay for their own label on the keypad) system. Do you get a ready light? Have you tried the factory default codes?

Have you gotten user and installer manuals?
 
  #3  
Old 02-23-08, 10:03 AM
F
Member
Thread Starter
Join Date: Oct 2007
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
At the suggestion of one freind I have just replaced the battery but the condition did not go away. Yes the ready light stays on along with system light. I have downloaded the PC1555 manual by DSC. I do not have any installer manual. What steps are required to get the system back to normal?
 
  #4  
Old 02-23-08, 09:42 PM
M
Forum Topic Moderator
Join Date: Jun 2000
Location: Gainesville, FL, USA
Posts: 17,634
Received 251 Likes on 230 Posts
Installer manual is easy, just run a websearch using the phrase "installer manual DSC PC1555". It's a dirt common system, you will find plenty of free downloads.

If none of the zone LEDs light when you press *2, the only thing I can suggest is to power down and restart the system. Without a trouble indication to work from, there is no useful information I can provide. Sometimes the system light gets "stuck" like this. Thus the reboot. Then all you should have is the need to reset the system clock.
 
  #5  
Old 02-24-08, 06:26 PM
F
Member
Thread Starter
Join Date: Oct 2007
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Got the installer's manual. Unplug the power supply and unhooked the battery. Connected battery and plugged back the power supply. Still the same symptons.
Ready Light stays on and System light stays on. Pressing *2 the System light blinks but no zone light comes on. This is strange. What is the easy way to reset it to default factory settings?? Please help!
 
  #6  
Old 02-24-08, 07:17 PM
M
Forum Topic Moderator
Join Date: Jun 2000
Location: Gainesville, FL, USA
Posts: 17,634
Received 251 Likes on 230 Posts
This is very odd. With a power down and reset, you should have gotten at least an 8 under *2 because the clock needs to be reset. The only thing I can think of is to try pressing and holding 1 for a couple of seconds and then trying *2 again. If you still don't get a real trouble indication, you can try a harware default. (See section 5.28 of your installer manual)

There is _nothing easy_ about this. You really should read the posts about DSC system programming already on this forum. These things are full of subtle little gotcha things where defaulting is concerned.

I'm not convinced that a default will fix this. This may be a failing system.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: