Zone Not Responding on My DSC PC1500


  #1  
Old 02-18-19, 12:00 PM
D
Member
Thread Starter
Join Date: Feb 2019
Location: Canada
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Zone Not Responding on My DSC PC1500

My Zone 2 controls 2 exterior doors. When I open either door, I get no response and light does not come on at my panel. I have replaced both sensors on the doors, ( even though I don't think it was the problem ) and no change. Today I disconnected one of the sensors and left wires open. No light or response. Shorted the 2 wires - no change. Any thoughts?
 
  #2  
Old 02-18-19, 12:24 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,450
Received 4,051 Upvotes on 3,634 Posts
Welcome to the forums.

You need to remove the wires from zone 2 at the panel to see what happens.
If no change..... try shorting the zone 2 terminals..... Z2 and C1/2 together.
 
  #3  
Old 02-19-19, 02:19 PM
M
Forum Topic Moderator
Join Date: Jun 2000
Location: Gainesville, FL, USA
Posts: 15,588
Received 314 Upvotes on 289 Posts
For this model, total failure of the input zone is a known failure mode. If you take the wires off at the main board, and the zone still shows closed, then it's 90% likely that the board is failing.

The small off chance other is that if one of these is allowed to run on a weak battery during AC power loss, the zone programming can get scrambled.
 
  #4  
Old 02-21-19, 07:45 AM
D
Member
Thread Starter
Join Date: Feb 2019
Location: Canada
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thx for info.
I did as you suggested. Got no change by removing wire on Zone 2 and likewise nothing happened when I crossed the wires as well. Looks like a failure in board.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: