Water pump issues.

Reply

  #1  
Old 07-10-19, 10:07 PM
Member
Thread Starter
Join Date: Jul 2019
Location: United States
Posts: 1
Water pump issues.

Hey all

I have an evaporative cooler and finally decided to turn on last weekend, but found that the water pump was not working or so I thought. I then unplugged and removed the water pump, so someone else could take it a local hardware store for a replacement. After doing this someone else in my house decided to troubleshoot the water pump and plugged into an outlet in the house. When plugged to the new outlet it seems to work. After hearing this I tried plugging a small utility light into the outlet for the water pump inside the cooler. This light too did not come either. Any other suggestions? Not sure how easy it is to replace the water pump outlet or if meant to be replaced

Thanks in advance
 
Sponsored Links
  #2  
Old 07-10-19, 10:35 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 50,954
Likes Received: 154
Welcome to the forums.

Pretty hard to offer detailed help without knowing what you have there.
Isn't there also a switch for the pump ? That could be bad.
A meter would probably be helpful for testing.

Pictures are always helpful...... How-to-insert-pictures.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes