Direct Vent Ghost Flames


  #1  
Old 02-02-13, 09:21 AM
B
Member
Thread Starter
Join Date: Feb 2013
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
Direct Vent Ghost Flames

I recently installed a Comfort Flame direct vent fireplace in my basement w/ stone surround. The fireplace lights and after a couple of minutes the flames start lifting off the burner thus pulling flames from sensor and shutting everything off. Inlet gas pressure and manifold pressure are fine which leads to lack of oxygen. If the firebox is opened up it works fine which proves this. Outside winds could be calm or windy, doesn't matter.

The venting is horizontal consisting of a 45* elbow,12" adjustable pipe, and horizontal high wind square termination. There is no blockage in the fresh air venting as far as I can tell. Forced air through it and was able to shine light up from inside the firebox and see it from the outside. Next I sealed the pipe overlaps w/high temp silicone as best I could reach from reaching in from the inside of the fireplace thinking the exhaust gas was recirculating with fresh air. None of this helps..any other suggestions?
 
  #2  
Old 02-02-13, 09:49 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,198
Received 1,531 Votes on 1,414 Posts
Inlet gas pressure and manifold pressure are fine
Did you actually check them or have them checked ?
 
  #3  
Old 02-08-13, 03:59 AM
B
Member
Thread Starter
Join Date: Feb 2013
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
I checked them at the gas valve. Inlet pressure is 7.4" wc and manifold is 3.5.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: