Help installing pilot feeder tube on gas fireplace


  #1  
Old 11-12-13, 06:58 AM
G
Member
Thread Starter
Join Date: Nov 2013
Posts: 7
Received 0 Votes on 0 Posts
Help installing pilot feeder tube on gas fireplace

I have a Majestic InstaFlame LP gas fireplace, DVR36 model. I am trying to replace the pilot feeder tube and need some assistance.

I have the new part from the manufacturer. When I install it, the threaded sleeve does not screw in as far as on the old part. You will notice that on the old part that the brass connector tip sits in the threaded sleeve somewhat, but on the new part it sticks out quite a bit.

I tightened to the point I feel is tight enough for small connectors like this, however there is a gas leak. I turned it another quarter turn, still leaks. At this point I stopped. I donít want to break anything. I verified I have the correct part number.

Valve end:




I am wondering, is it supposed to be tightened more so that the brass fittings compress and mate? There is some evidence on the old part which you can see in the second pic. The new part is the correct length, has the correct size fittings (threads) and everything seems to be a match, it just doesnít seem to seat very well. I donít want to apply brute force and end up breaking the value or something.

Pilot end:


Thanks!!
 
  #2  
Old 11-12-13, 10:00 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,193
Received 1,530 Votes on 1,413 Posts
The parts look very similar but somehow must be slightly different. You can go pretty tight to mate the ground brass end. You should be using a line wrench or a six sided box end wrench at the valve end. You may need a second wrench on the valve if there is a fitting there.
 
  #3  
Old 11-13-13, 12:33 PM
G
Member
Thread Starter
Join Date: Nov 2013
Posts: 7
Received 0 Votes on 0 Posts
This new part is definitely not working. When I tried to tighten it at the valve, it started to strip the threads. I managed to back it out and I can still screw the old part in. Man this is frustrating. I am stuck. I sent the pics to a dealer this morning, no response yet.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: