Electric fireplace troubleshooting

Reply

  #1  
Old 04-02-19, 05:04 PM
S
Member
Thread Starter
Join Date: Apr 2019
Posts: 5
Received 0 Votes on 0 Posts
Electric fireplace troubleshooting

I bought a home and made the all to wise decision to lean on the knowledge/advise of my agent about the malfunctioning eletric fireplace insert. The fireplace is a vermont casting vcef36. Everything with the fireplace seems to be in working order except the actual heating. The fan blows, but the heating element does not produce heat. Both a new circuit board and heat/blower part have been replaced and still nothing. I an drawing closer to my knowledge threshold at this point. Vermont casting is an old and out dated company. Additionally these electronic fireplace inserts seem to be uncommon as I've found very little info about them online. At this point I am looking for any troubleshoot suggestions, or similar issues others have had.
 
Sponsored Links
  #2  
Old 04-02-19, 05:30 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 58,446
Received 1,021 Votes on 947 Posts
Welcome to the forums.

Should be relatively easy to repair as it's a basic setup. You said the fan is working which may mean the thermal limiter is open. You can check it with an ohmmeter. It should show as a short (0 ohms).

Name:  vc.JPG
Views: 74
Size:  31.7 KB

Your............. Fireplace manual
 
  #3  
Old 04-16-19, 03:18 PM
S
Member
Thread Starter
Join Date: Apr 2019
Posts: 5
Received 0 Votes on 0 Posts
Back with an update

I'm definitely not an electrical expert, so with the advice given, I consulted with an electrician and really didnt get much further. Other than nothing is wrong electrically, and neither of use can seem to accurately identify this "limit switch" shown in the manual. (Disclaimer: he was a young kid who i wasnt 100% confident in). switches I've seen are usually some round or box shaped items that should be pretty obvious to see. I've attached a few photos if that helps. There is a small assembly that runs along the the heat/fan unit and we could not identify. I would assume if that was anything comparable to a limit switch, it would be working fine on the new part. Although the limit switch is identified in the electrical diagram of the manual, it's not listed as a part. Also couldn't readily find any replacement info for this specific unit online. With all of this I'm still sort of at square one again. Lol. Any feedback guys? And thanks for the help already provided
 
  #4  
Old 04-16-19, 03:43 PM
S
Member
Thread Starter
Join Date: Apr 2019
Posts: 5
Received 0 Votes on 0 Posts
Here is just like what I have.

Name:  fan_heater.jpg
Views: 59
Size:  52.9 KB
 

Last edited by PJmax; 04-17-19 at 10:51 AM. Reason: imported pic from link and labeled.
  #5  
Old 04-17-19, 10:51 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 58,446
Received 1,021 Votes on 947 Posts
I imported the picture from that catalog. I circled the thermal limiter. It is a two legged device that is a one shot thermal safety switch. With the unit unplugged..... you should measure close to 0 ohms across it.

I'm looking again at the picture and can't tell what the thing is to the right of my circle. That could be a cycling thermostat with the part in my circle as a safety fuse. A picture of your actual heater would be more helpful.
 
  #6  
Old 09-15-20, 06:38 PM
S
Member
Thread Starter
Join Date: Apr 2019
Posts: 5
Received 0 Votes on 0 Posts
One last try

Hi, its been awhile after having trouble with attaching photos along with sort of giving up on the repair, I'm back for a final shot before finally exploring my options in replacing the unit. I've attached a photo of the actual part in my possession. Any advice? Thanks

Replacement part
 

Last edited by PJmax; 09-15-20 at 07:07 PM. Reason: resized pic
  #7  
Old 09-15-20, 06:41 PM
S
Member
Thread Starter
Join Date: Apr 2019
Posts: 5
Received 0 Votes on 0 Posts
Photo

Original part
 

Last edited by PJmax; 09-15-20 at 07:09 PM. Reason: resized pic
  #8  
Old 09-15-20, 07:11 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 58,446
Received 1,021 Votes on 947 Posts
Ok.... I see the two parts. They appear to be the same or very similar.

I'm guessing you tried the new part in and no heat ?
Do you have a meter ?
I can help you to use it if you're not sure how.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: