Overhead Door Legacy 696CD/B light not working


  #1  
Old 10-17-13, 07:35 AM
S
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
Overhead Door Legacy 696CD/B light not working

I have a working "Overhead Door Legacy 696CD/B" garage door unit but the light bulb which supposed to come "On" during opening/closing of the garage door isn't working.

I tried replacing the light bulb but it doesn't work (I know the light bulb is good) and I reset the power by unplugging the power cord but it doesn't work.

I know if I call the repairmen, it's going to cost me an arm and a leg and was wondering if anyone else had a similar experience with a possible fix.

Thank you in advance.
 
  #2  
Old 10-18-13, 06:38 AM
czizzi's Avatar
Member
Join Date: Jul 2007
Location: USA
Posts: 7,388
Received 15 Votes on 13 Posts
The wall switches for many garage door openers have a separate button that controls the lights on the opener. You may have inadvertently activated the switch which shuts down the lights when the door is operating.
 
  #3  
Old 10-18-13, 08:25 AM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 21,112
Received 4 Votes on 4 Posts
Unplug the opener and carefully bend the center contact in the bulb holder up (if possible). I have seen more than a few lamps where the tab loses tension. Some can't be bent and you have to find a bulb with a high center contact. If you have a very high wattage soldering iron you can add to the bulb to raise it.

You can carefully test for power if you know how to use a multimeter. If no power, then bending won't help.
 
  #4  
Old 10-22-13, 08:53 PM
F
Member
Join Date: Oct 2013
Posts: 1
Received 0 Votes on 0 Posts
I am having the same issue. Please let me know what fixes your problem.

Thanks
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: