Roses growing but few buds

Reply

  #1  
Old 07-09-17, 07:40 AM
Member
Thread Starter
Join Date: Oct 2001
Location: USA
Posts: 284
Received 0 Votes on 0 Posts
Question Roses growing but few buds

I have three lavender patio roses in planters on my south-facing patio. I believe they get the required 6 hrs sun. I water each day (very hot temps in the midwest).
The bush is putting out long, thin stems which are green, but few blooms (maybe one at the very end of the stem).

Any ideas what could be causing this to occur?
 
Sponsored Links
  #2  
Old 07-09-17, 07:46 AM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Location: USA
Posts: 23,371
Received 229 Votes on 211 Posts
Could be too much nitrogen or not enough. Are you fertilizing at all? Have you deadheaded the old blooms?
 
  #3  
Old 07-09-17, 05:33 PM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 21,073
Received 241 Votes on 220 Posts
Did you prune at the end of the season last year or early in the season this year?
 
  #4  
Old 07-10-17, 08:14 AM
Member
Join Date: Feb 2006
Location: USA
Posts: 6,569
Received 4 Votes on 4 Posts
Roses

Deer love the new, tender growth just ahead of the blooms. Look for severed shoots.
 
  #5  
Old 07-17-17, 07:17 AM
Member
Join Date: Mar 2007
Location: Oregon
Posts: 696
Received 4 Votes on 4 Posts
How long have you had them.....are they bush roses ?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: