Mr. Heater firing problem

Reply

  #1  
Old 02-15-17, 09:49 AM
Member
Thread Starter
Join Date: Feb 2017
Location: United States
Posts: 3
Mr. Heater firing problem

Hello, new to this site. I have a Mr Heater HSU75 in my garage, has worked flawless for 4 years. Went out this morning and hit the tstat, Heater did what it usually did but wouldn't light. I did some looking and noticed the "Tick tick Tick" you hear is very faint. The heater is clean inside no cob webs or anything of the sort. I decided to grab a long handled lighter. I shut everything down and waited 10 minutes. Turned elec back on and fired her up. This time I took the long lighter and when I heard the faint tick I lit the lighter. Heater fires and works great. I did this 3-4 times. I think maybe a bad ignitor? Bit when I look for the ignitor I see two things that look like the ignitor. Are there two? Any help would be great Thanks in advance. I see no spark at either one, but not sure which is supposed to spark!
 

Last edited by Shadosprit; 02-15-17 at 11:31 AM.
Sponsored Links
  #2  
Old 02-15-17, 11:12 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 46,782
Welcome to the forums.

That is a direct spark ignition.
You are probably seeing the spark probe and the flame sensor rod.
If the spark is sparking to the burner then it is working properly.

Look at the control board. The green LED should blink a trouble code.

Name:  mr heater codes.jpg
Views: 435
Size:  41.2 KB
 
  #3  
Old 02-15-17, 11:31 AM
Member
Thread Starter
Join Date: Feb 2017
Location: United States
Posts: 3
I had two flashes, once i turned off the power I did it again now its just a nice steady flash, (after I light it with BBQ ignitor). There are two pieces in question one is at the top of the burner its a long circular white thing with a rod coming out of it. There is a white wire feeding it, the other at the bottom of the burner looks the same but there are two rods coming out of it, feed with a red wire. I'm not sure which is the ignitor. Tried googling it but no luck. I see no spark at either one, but not sure which is supposed to spark!
 
  #4  
Old 02-15-17, 11:53 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 46,782
On page 17 of the manual shows a parts breakdown of the burner assembly area.
Look at parts 3 and 6.

szmanuals/be1149d9f3f8972ccb3141c009659fc4.pdf
 
  #5  
Old 02-15-17, 12:01 PM
Member
Thread Starter
Join Date: Feb 2017
Location: United States
Posts: 3
Must be the bottom one, the one with the two leads (although it only shows one lead in that pic). Found another site guy had same problem as me, it was his circuit board. I have a call into Mr. Heater to talk to a tech guy. This blows, always something
 
  #6  
Old 05-26-18, 03:58 PM
Member
Join Date: May 2018
Location: Canada
Posts: 1
Mr heater flashes 3 times

Hi i am new and not sure how to start a thread to discuss my problem. My unit flashes three times thus indicating the pressure switch however if the blower does not start such as in my case I would expect the error to indicate this.. I have checked the lower motor and it works however will not turn on. I would appreciate any insite..

thank you
Roger
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes