Kenmore 74701 pilot free ignition


  #1  
Old 08-03-04, 04:36 PM
swellguy
Visiting Guest
Posts: n/a
Question Kenmore 74701 pilot free ignition

I hope someone out there can help me out. I've had a Sears Kenmore gas range in my house for 18 years - it's usually worked great. It worked fine last night. Just tonight the top burners won't turn on. Frankly, I hadn't run into this problem that I can remember, so I have no idea how to correct this malfunction. When I push down and turn, I don't hear the normal clicking sound right before the burner goes on like I usually do.

What's wrong?
 
  #2  
Old 08-04-04, 07:35 AM
Sharp Advice's Avatar
Admin Emeritus
Join Date: Feb 1998
Location: The Shake and Bake State USA
Posts: 9,927
Upvotes: 0
Received 7 Upvotes on 6 Posts
Hello swellguy. Welcome to my Gas Appliances topic and our Do-It-Yourself Web Site.

Be sure there is electric to the appliance. If the hot surface glow ignitor (HSI) in the oven works, there is electric to the appliance.

Also be sure the problem is the same at all top burners. If it is, the spark ignition module is defective. If not, the switch to only the effected burner is defective.

Retail appliance parts dealers can also help determine what the possible problem may be also. They will need the make, model an serial numbers. Appliance parts dealers are an excellent source for original replacement parts. Dealers are listed in the phone book under appliances.

Kindly use the reply button. Any additional information you add will remain within this posting. Using this method also moves the topic back up to the top of the list automatically.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: