Tappan gas oven problem


  #1  
Old 11-29-05, 09:26 AM
momof46
Visiting Guest
Posts: n/a
Question Tappan gas oven problem

My Tappan gas oven with a glow plub ignition will light and operate during warm weather but not during cold weather. I don't want to replace the wrong part. Glow plug comes on in both instances and appears the same. HELP
 
  #2  
Old 11-29-05, 12:19 PM
Sharp Advice's Avatar
Admin Emeritus
Join Date: Feb 1998
Location: The Shake and Bake State USA
Posts: 9,927
Upvotes: 0
Received 7 Upvotes on 6 Posts
Hello momof46 and Welcome to the Do It Yourself Web Site and my Gas Appliances topic.

Cannot say I have ver encounter such conditions. So cold oven would not ignite. Only possible first attempt solution is to replace the ignitor and hope for the best.

Retail parts dealers and appliances parts stores can also help determine what the possible problem may be based upon that specific brand and model. Bring the make, model and serial numbers. Dealers and appliances parts stores are listed in the phone book.

Additional Suggestions:
Read the manufacturers online web site for product information, problem possibilities, causes, solving methods, part locations, disassembly, reassembly methods, repair procedures, pictorials, schematics, repair and or owners manuals which may be available online.

Cautionary Note:
Before attempting any repairs, be sure to unplug the appliance from the wall receptacle power source first.

Help Link. Plenty of info here:
Range-Stove-Oven-Broiler Basic Help Information & Manufacturers Web Sites: http://forum.doityourself.com/showthread.php?t=159808

Use the reply button to add additional information or questions. Using this method keeps or moves the topic back up to the top of the list automatically.

Web Site Host, Forums Monitor, Web Sites Moderator Hiring Agent, Gas Appliances Topic Moderator & Multiple Forums Moderator & Natural Gas Appliance Diagnostics Technician.

Personal Driving Safety Reminder:
Buckle Up & Drive Safely.
"The Life You Save, May Be Your Own."
 
  #3  
Old 01-03-06, 07:21 AM
momof46
Visiting Guest
Posts: n/a
Thumbs up

Just thought I'd let anyone know....I replaced the ignighter....that was it....works fine now. Thanks for the help, Sharp Advice.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: