Gas oven


  #1  
Old 04-10-10, 02:04 PM
D
Member
Thread Starter
Join Date: Apr 2010
Posts: 1
Received 0 Votes on 0 Posts
Gas oven

Broiler works but oven wont heat could it still be ignitor?
 
  #2  
Old 04-10-10, 04:25 PM
riggstad's Avatar
Member
Join Date: Jan 2010
Location: Philly Burbs
Posts: 174
Received 0 Votes on 0 Posts
had this same problem. It was a Kenmore gas range with electric start.

The Broiler would flame, but the oven wouldn't. Eventually the oven would light but it got worse and worse. I ended up buying a new range for lack of available info on the internet.

That was before I found this site. Maybe someone will have some knowledge about what the issue most likely is and how to go about repairing it.
 
  #3  
Old 04-11-10, 08:04 AM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 5,499
Received 1 Vote on 1 Post
I'm presuming you have a hot surface ignitor ignition system.

You probably have two burners, one for the broiler and one for baking. Each of those would have it's own hot surface ignitor.

I'm presuming you can see the HSI for the broiler get white hot, then the gas turn on and light off the HSI.

The burner for baking should light up the same way. If it's not you can take the HSI out and inspect it ----usually you will see a crack on the element which indicates that it needs to be replaced.
 
  #4  
Old 04-12-10, 01:01 PM
M
Member
Join Date: Dec 2004
Location: San Jose,Ca
Posts: 1,573
Received 3 Votes on 3 Posts
Are you able to take volt or amp reads?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: