Setting range of temperature 'wave' on gas oven.

Reply

  #1  
Old 11-02-11, 09:09 AM
.
Member
Thread Starter
Join Date: Nov 2011
Location: United States
Posts: 2
Received 0 Votes on 0 Posts
Setting range of temperature 'wave' on gas oven.

I notice that while the oven flame will light, and the sensor seems to correctly preheat to any set temperature, once the oven is preheated, the flame repeatedly turns on then immediately shuts off, again and again. Each step in this cycle is preceded by the audible 'click' of what I assume is the bake relay.

My diagnosis is that both the sensor and the relay are working, but something in the way the oven sets the degrees below which the flame is called for is kaput. None of the discussions I've been able to find online even describe this. I'm not sure I can even buy a part to fix this, as it appears that I would need to get a whole new control panel. How much is this repair likely to cost, if you can guess what the problem is?
 
Sponsored Links
  #2  
Old 11-03-11, 06:03 AM
.
Member
Thread Starter
Join Date: Nov 2011
Location: United States
Posts: 2
Received 0 Votes on 0 Posts
I forgot to specify that this is a digital oven. I don't think it matters one way or the other, but I tested the sensor, and got a reading of 1050 ohms at a little under 60 degrees (diagram says 1100 at room temp is optimal).
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: