Whirlpool Accubake Oven does not work

Reply

  #1  
Old 11-27-11, 05:22 PM
R
Member
Thread Starter
Join Date: Nov 2011
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
Whirlpool Accubake Oven does not work

Whirlpool stove (model # GW395LEPS03) control panel clock works but other buttons do not work. unable to turn oven on, burners work fine but not controlled by this control panel. No apparent damage to circuit or cables. I found a new control panel circuit board for sale but it is expensive. could it be something else? is there a separate touch pad?
 
Sponsored Links
  #2  
Old 11-27-11, 07:09 PM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 5,503
Received 0 Votes on 0 Posts
Odds are the circuit board needs to be replaced.

I doubt I could be of much help over the internet in eliminating other possibilities.

The basic method of diagnosing such problems is the "black box" method. It presumes you have a black box about which you know nothing except that it has various inputs and outputs.

If you have the proper inputs, you should have specific outputs. If you don't--- replace the black box.

You'd have to come up with your own tests for additional confirmation. Based on your previous post it sounds like you probably have the right inputs but aren't getting the right outputs.

You have power to the circuit board because the clock works.
 
  #3  
Old 11-28-11, 09:45 PM
R
Member
Thread Starter
Join Date: Nov 2011
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
Thanks....it does sound like a new circuit board
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: