thermador prsg304s burner problem


  #1  
Old 01-31-13, 08:59 AM
R
Member
Thread Starter
Join Date: Jan 2013
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
thermador prsg304s burner problem

I have a 1996 Thermador prsg304s range. All burners light and work properly when the unit is first turned on cold. When oven has been on for approximately 20 minutes, the left front burner (a simmer burner) no longer will work. The igniter sparks but there is no longer any gas flow to that burner. All other burners still operate properly. That burnerner will not relight until the oven has been turned off for at least a couple of hours. Any ideas would be appreciated.
 
  #2  
Old 01-31-13, 07:03 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,837
Received 1,475 Votes on 1,363 Posts
I'm assuming natural gas ?

All the burners use a common gas regulator.....so that would not be an issue.
It would suggest a problem with the gas valve for that burner.
gas valve
Bosch 415499 Valve Body (simmer) - AppliancePartsPros.com

Apparently there is a potentiometer that is attached to the gas valve and may also cause your problem. Read the following link page all the way thru.
Bosch 422748 Potentiometer - AppliancePartsPros.com

http://www.searspartsdirect.com/part...&prst=&shdMod=
 
  #3  
Old 03-18-13, 03:33 PM
M
Member
Join Date: Dec 2004
Location: San Jose,Ca
Posts: 1,573
Received 3 Votes on 3 Posts
Did you try putting a pan of water on it, if memory serves me the burner is designed to cycle on/off
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: