Whirlpool Gas Oven Delayed Ignition

Reply

  #1  
Old 02-12-13, 08:25 AM
B
Member
Thread Starter
Join Date: Dec 2012
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
Whirlpool Gas Oven Delayed Ignition

When we start our oven you can smell gas briefly. We had the gas company come out and at first he said it was fine. But after a couple of minutes he stated that the oven does in fact have delayed ignition. There is no noise, but I want to hear what you think. Last month we were on vacation and when we got back the gas co had shut off our gas for non-payment. We had them come and turn the gas on the same day and that is when this issue started. A strange coincidence? Or is there some adjustment I have to make? Please advise...
 
Sponsored Links
  #2  
Old 02-12-13, 08:32 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 58,565
Received 1,041 Votes on 965 Posts
A strange coincidence ?
No....the line may have air in it and it will take a little while for it to get purged out.

Another issue that can cause delayed ignition is a dirty/corroded/rusted burner that may have holes plugged in the igniter area. The repairman should have checked for that.
 
  #3  
Old 02-12-13, 09:08 AM
B
Member
Thread Starter
Join Date: Dec 2012
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
Thanks I will check that myself...

It wasn't a repair man. It was a gas company employee who simply measured for gas leak...
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: