Blanco gas cooktop with electric ignition

Reply

  #1  
Old 03-28-13, 09:18 PM
G
Member
Thread Starter
Join Date: Mar 2013
Location: Australia
Posts: 2
Received 0 Votes on 0 Posts
Blanco gas cooktop with electric ignition

I have a blanco gas cooktop with electic ignition, I press and turn the knob to light but nothing happens no clicking and i cant smell any gas , It was working yesterday .The gas hot water is working so gas it getting into the house. Electricity is working on other appliances. Does any one have any ideas as to what is going on or what i may be doing wrong. Thanks
 
  #2  
Old 03-31-13, 12:57 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,469
Received 1,420 Votes on 1,313 Posts
Welcome to the forums from down under.

I can't find much service info on Blanco products. I've found parts centers and the controls look similar to the ones used here. They appear to use separate switches on the gas valves for the spark ignition which means that even if the spark system was not working you would still get gas.

So based on that I can't tell you why you don't get spark or gas. You may have to contact Blanco service directly in Au.
 
  #3  
Old 04-07-13, 01:36 AM
G
Member
Thread Starter
Join Date: Mar 2013
Location: Australia
Posts: 2
Received 0 Votes on 0 Posts
sorry I do get gas, i couldnot smell it but once i put a match near the burner i got fire. so now it appears the electric ignition is my problem which i need to buy and replace. Thanks. Gazzah
 
  #4  
Old 04-07-13, 01:52 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,469
Received 1,420 Votes on 1,313 Posts
You should check with a voltmeter at the spark module to see if you're getting your mains voltage to it. Turn on a gas valve and the voltage should appear on the spark module. If it does.....the module is bad and must be replaced.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: