Kenmore Wall Oven wont heat up to desired temp.


  #1  
Old 06-27-13, 02:36 PM
D
Member
Thread Starter
Join Date: Jun 2013
Location: usa
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Exclamation Kenmore Wall Oven wont heat up to desired temp.

I posted a couple of days ago, but didnt have the product number, and now i cant find that post so im re-posting with the product number.. sorry . My issue is, my oven turns on just fine, ignites, but only stays on for 1-3 minutes before saying its reached the temperature i put it in, and it doesnt even get close. The product number is 911.3012990. Im desperate to have an oven that works, so I can stop having to use the microwave and have soggy tasteless food! Plz Help!
 
  #2  
Old 06-27-13, 09:16 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 71,109
Received 3,198 Likes on 2,873 Posts
You couldn't find your post because it was in the electric appliance forum

No problem......good to see you back.

As to the answer I left you in that other thread.....the temperature sensor would appear to be defective. It could also be a wiring problem to that sensor although that is less likely. Normally I would say just replace the sensor but for this oven it appears to be unreasonably expensive.

The FSP #WB21X5301 can be used to shop for the sensor. You can also check with a local appliance parts place where they could even check your old one for you.

In the link below is one place that carries the part. The also have a video there to show you how to test it.

Oven Sensor WB21X5301 Order now for same day shipping. 365 day return policy. Repair Clinic
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: