Kenmore Oven Failure


  #1  
Old 12-16-13, 04:00 PM
F
Member
Thread Starter
Join Date: Jan 2009
Location: Kansas
Posts: 49
Received 0 Votes on 0 Posts
Kenmore Oven Failure

My daughter and her family have a Kenmore Model No. 790-70602014 stove. The oven fails to heat at all. Assuming that the igniter was bad, I replaced it. No difference. The display over the stove reads OK. Set the temp, etc. Nothing happens in the oven. The igniter will not glow at all.

It seems to me that the order for the igniter to get some electric current is not happening. Would the culprit be the control board for the model? The stove is only one year old.

BTW, this stove has the broiler in the bottom drawer. I could not believe that these models were still being made, since my mother had one when I was a boy in the 1950s.

Regards,
Chuck
 
  #2  
Old 12-16-13, 04:54 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,651
Received 1,611 Votes on 1,483 Posts
I moved your thread to the gas appliance forums.

I'm going to need a little more info.
I show the bottom drawer as a warming drawer..... not a broiler..... is that correct ?
Does the broiler work ? Should be in the top of the oven.
Is this also a convection oven.... and does that work ?

I'm working off a Sear's wiring diagram that doesn't list the model numbers.... I just want to make sure it's the right one.

318271933
 

Last edited by PJmax; 12-16-13 at 05:31 PM. Reason: added diagram #
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: