Possibly a pressure problem?


  #1  
Old 02-06-14, 07:23 AM
H
Member
Thread Starter
Join Date: Feb 2014
Location: USA
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
Possibly a pressure problem?

Hi I have a frigidaire gas stove (we use propane) and I am having problems with it not working properly. It wasn't lighting (the stove top or oven) so we replaced the requlator thinking that was the problem. Now that we replaced the regulator it lights but the flame from the burners are very low. Tried adjusting the valve for the oven but it doesn't seem to do anything other than make a stronger smell of propane from the oven when it's on. Is there another part I should be looking for? Thank you
 
  #2  
Old 02-06-14, 09:13 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 28,351
Received 2,319 Upvotes on 2,064 Posts
Regulators rarely fail but it can happen. Do you have any other gas appliances in the house? How are they performing? Is this a new stove? Was it previously working OK or has it always had this problem?

If other appliances are not burning correctly or have lazy flames it is possible that there is a problem with the regulator on the tank or side of your house. I have seen one that froze because of moisture in the propane. It only let a very small amount of gas through. I would also confirm that your tank is not empty.
 
  #3  
Old 02-06-14, 09:49 AM
H
Member
Thread Starter
Join Date: Feb 2014
Location: USA
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks for the reply the only other gas appliances we have are our furnace and a gas fireplace. Our propane company just came and refilled our tank about 3 weeks ago so we're not empty. Our furnace seems to be working ok (as in it turns on, since I'm not that knowledgeable on it) and our fireplace seems to have quite a bit of build up when we run it, but it does run. I had planned to call the propane company to ask then to check their regulator but I believe this is only the second winter we've had since they put a new one on
Oh and we've had the stove for about 4.5 years now
 
  #4  
Old 02-06-14, 09:58 AM
H
Member
Thread Starter
Join Date: Feb 2014
Location: USA
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
Oh and if it makes any difference the flame on the burner when it comes out is blue (not orange) but even when it is on high it looks like when I would normally have it on low. And when I do turn it down to low there is either barely a flame or it just goes out all together
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: