weak/no sparking - Thermador gas professional (unsealed) cook top


  #1  
Old 02-15-14, 10:54 AM
S
Member
Thread Starter
Join Date: Dec 2011
Location: usa
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Question weak/no sparking - Thermador gas professional (unsealed) cook top

Gas flows (I can light any burner with a match).

However, one burner row (both front and back) won't spark. The other row sparks (albeit weakly). Curiously, I cleaned the area near the ignitor and cured the original problem.

However, a week later, burners on the other row stopped sparking - either no "clicks" from the ignitor or a single click. It "feels" like a cleaning issue (the ignitor area is heavily corroded, so a ground may be failing) but it may be something more substantive. I tried simply jiggling the ignition wire when cleaning the area with no effect. This is a vintage 1990's Thermadore which has been heavily used, so perhaps its time has come after 20 years.

It would be nice if a girl (me) could restore this thing.

Thoughts?
 
  #2  
Old 02-15-14, 11:43 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,981
Received 4,152 Upvotes on 3,729 Posts
Welcome to the forums.

It's either a problem with shorting igniter electrodes or a defective spark module.
There are several different spark modules used in the Thermadors and are based on model number.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: