Frigidaire (Gas) oven won't light

Reply

  #1  
Old 09-26-14, 10:10 AM
T
Member
Thread Starter
Join Date: Oct 2010
Location: USA
Posts: 221
Received 0 Votes on 0 Posts
Frigidaire (Gas) oven won't light

I have a Frigidaire oven (Model # FGFL66ASA, Serial # VF23004420) that won't light. Power & gas supply is good. Stove top burners light OK. The ignitor glows bright orange but that's all that happens. Is there a way to test the gas valve or a next step in the troubleshooting?
Any input is appreciated!

TexasFire
 
Sponsored Links
  #2  
Old 09-26-14, 10:18 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 23,711
Received 621 Votes on 574 Posts
How old is the stove? Ignitors do go bad and they are probably the most common thing I run into. If your stove is 5 years old or older I'd consider it a possibility even though you see it glowing. If you have a propane or butane torch you can further heat the ignitor when it's glowing and if the gas turns on and burner lights then you've confirmed that it's the ignitor. Usually any more I don't bother with the torch and just replace the ignitor.
 
  #3  
Old 09-26-14, 06:39 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,085
Received 1,110 Votes on 1,030 Posts
The actual next step would be to use an ammeter or current probe to measure the current draw of the igniter but like Dane said..... replace it.

The igniter is in series with the gas valve. When the igniter reaches its white hot stage.... the current goes up quickly and opens the valve.

The manufacturer part # 5303935066.
You can use that part number to search online for a replacement or at your local appliance parts retailer.
 
  #4  
Old 09-26-14, 09:04 PM
T
Member
Thread Starter
Join Date: Oct 2010
Location: USA
Posts: 221
Received 0 Votes on 0 Posts
Yep, it was the igniter! The part was a little over $60 so to be on the safe side I performed a test I found on YouTube by clamping an ammeter around one of the leads to the igniter. The video stated it should be 3.6 - 3.8 amps. Mine came up 2.7 amps. The new one I installed hit 3.6 right off the bat & the gas valve opened right up!

Thanks!

TexasFire
 
  #5  
Old 09-26-14, 09:35 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,085
Received 1,110 Votes on 1,030 Posts
Great job. Thanks for stopping back and updating us.... it is appreciated !
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: