Whirlpool 465 gas oven shuts down 2-3 sconds.

Reply

  #1  
Old 11-12-15, 11:28 AM
M
Member
Thread Starter
Join Date: Nov 2015
Posts: 5
Received 0 Votes on 0 Posts
Whirlpool 465 gas oven shuts down 2-3 sconds.

This oven has separate spark igniters for broiler & oven. The oven comes on full blast and shut down 2-3 seconds. Broiler did noting so I replaced the spark igniter ($40.) Now the broiler will light for 2-3 seconds just like oven. In a posting from 2005 on this problem this was said.
"has a spark ignitor, which lights a pilot flame, which in turn heats a safety element (fluid safety element (ASO) which than allows the gas valve to open and than the burner ignites! WOW! That changes the complete diagnostics process"
Now this stove does not operate that way, instead the gas comes on full blast with either the oven or broiler and goes out in 2-3 seconds. Thanks in advance for any help.
 
  #2  
Old 11-12-15, 11:47 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,398
Received 1,399 Votes on 1,296 Posts
Welcome to the forums.

Whirlpool 465 is a trade name.... not a model number.

The following link has some basic servicing info for that series. According to it you do not have spark ignition for the broiler and oven. You have a hot surface igniter.

I've never seen the gas just come on for a few seconds and shut off. You should watch the oven ignition sequence. When calling for the oven to heat.... the igniter should start to glow. It should glow for approx 30 seconds until it gets white hot and then the burner should light.

A complete model number would be required for exact confirmation.


whirlpool/Service/SrvTechAdm.nsf/FILE/4322089.pdf
 
  #3  
Old 11-12-15, 03:11 PM
M
Member
Thread Starter
Join Date: Nov 2015
Posts: 5
Received 0 Votes on 0 Posts
Thanks for the link, however it really is a spark igniter simular to burners.

Strange as it might seem.
 
  #4  
Old 11-12-15, 03:26 PM
M
Member
Thread Starter
Join Date: Nov 2015
Posts: 5
Received 0 Votes on 0 Posts
spark igniter VS glow gas oven igniter.

The glow style is obviously more popular, however mine has the spark igniters, both for oven and broiler similar to the stove top igniters but much longer. Still I appreciate the link and trying to help me.
 
  #5  
Old 11-12-15, 05:12 PM
M
Member
Thread Starter
Join Date: Nov 2015
Posts: 5
Received 0 Votes on 0 Posts
mode number is SF385PEGQ Whirlpool stove.

Maybe this will help. model no SF385PEGQ
 
  #6  
Old 11-12-15, 05:27 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,398
Received 1,399 Votes on 1,296 Posts
I'm aware of the spark system you have. It's been a problem in the past. I'm trying to find my tech sheet on it.

Can you tell me what the digit is after the Q ? (you didn't post it)
 
  #7  
Old 11-12-15, 06:14 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,398
Received 1,399 Votes on 1,296 Posts
Your stove uses DSI (direct spark ignition). There is no intermediate pilot light.

After researching your stove.... the spark igniters are connected with one wire. The DSI board sends out high voltage to create the spark and reads the flame thru the igniter. The igniter must be IN the flame when the burner lights. If the spark rod gets dirty the flame sense won't operate properly. You can clean the igniter road with a scotchbrite pad. The broiler with the new igniter should work fine.

Some things to check.... make sure the polarity of the receptacle where the oven is plugged in is correct. The small blade to ground is 120v and the larger blade to ground should be 0v.

Make sure the ground connection is ok as well as the DSI mounting screw is tight. Any loss of ground from the board to the burner will interfere with the flame sensing circuitry.

Other than this information..... replace the DSI board.
Spark module W10331686 - Repair Clinic
 
  #8  
Old 11-13-15, 06:37 AM
M
Member
Thread Starter
Join Date: Nov 2015
Posts: 5
Received 0 Votes on 0 Posts
Whirlpool spark modual

Thanks PJmax. the units has suffix of 5, sp385pegq5. Really appreciate the advice on checking ground and replacing board.
Just curios, if burners on top all work good could it still be the wiring? I will check it out.
Thanks again.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: