A GE oven Q


  #1  
Old 03-05-23, 04:53 AM
C
Member
Thread Starter
Join Date: May 2016
Location: usa
Posts: 62
Upvotes: 0
Received 0 Upvotes on 0 Posts
A GE oven Q

I have a JGBS10DEM3WW gas oven/stove and the oven won't light. The igniter glows perfectly but the gas isn't being sent through. After the igniter was on for a couple of minutes I took a pole and whacked the regulator and it came on. I did this a couple of times so I don't believe it's a loose wire.

Is there anything else I should look for to be wrong other than the regulator?

Thank you.

Chuck
 
  #2  
Old 03-05-23, 02:19 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,746
Received 4,117 Upvotes on 3,697 Posts
The igniter doesn't have to glow perfectly..... it needs to glow pretty near white hot in order for the safety valve to open. I'd recommend changing the igniter. It's the only part that can cause an issue other than the gas safety valve and they rarely go bad. You can check the circuit if you have a clamp-on ampmeter. You need to measure better than 3A AC on one of the igniter wires.

WB13K21
I like to use the OEM igniters.................. GE WB13K21 igniter

 
  #3  
Old 03-06-23, 01:04 AM
C
Member
Thread Starter
Join Date: May 2016
Location: usa
Posts: 62
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thank you P.J.
I will go by tomorrow night and get back to you.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: